
 

 
 
 
 
 
 
 
 

WAVEWIN 

SYSTEM MONITORS 
 
 
 
 
 
 
 
 
 
 
 

QUICK START 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
SOFTSTUF, INC. 

SOFTWARE STRUCTURE FOR UNLIMITED FUNCTIONALITY 
P.O. BOX 40245 

PHILADELPHIA, PA 19106-0245 
1-800-818-3463 · 215-922-6880 

www.softstuf.com  
www.wavewin.net  

http://www.softstuf.com/
http://www.wavewin.net/


 

 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

Copyright © 1991-2011 by Softstuf, Inc. 
All rights reserved. 
Printed in the United States of America. 
 
Last Update: 06/01/2011 
 
Acknowledgments 
 
Wavewin is a registered trademark of Softstuf Incorporated. 
Windows is a registered trademark of Microsoft Corporation. 
All other products and brand names are trademarks or registered trademarks of their respective holders. 



 

 



 

Preface 
 
This document contains information about the Wavewin Dispatch table and the Fault Data Manager 
applications. 
 
This document is intended for use by individuals working in protection, engineering, and system operations.
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C H A P T E R  1  

System Requirements & Installation 
 
This chapter lists the system requirements needed for installing and running the Wavewin software.  It also 
describes the installation procedures and provides technical support information. 

System Requirements 

The system requirements are listed below. 

 
� An IBM or compatible PC with an 80486 microprocessor or higher. 
� 500 Megabytes of memory. 
� 2 gigabytes of available hard disk space. 
� A VGA, 8514/A, or compatible graphics adapter. 

� Microsoft Windows version XP or higher. 

Installation 

The system files are distributed in a compressed format.  To install the software follow the instruction for the 
type of storage media distributed with this manual. 
 
Web: To install the software from the Web access the www.wavewin.net web site. Under the “Wavewin 
Upgrades” link click on the Wavewin application to download. Enter your username and password. The 
username and password are case sensitive. Click on the software link to download the latest system’s 
executable files. Open the zip file and run the install.  
 
CD: To install the software using a CD place the CD into the CD drive.  The installation program will run 
automatically. If the installation program is not displayed, navigate to the CD’s root drive and double click on 
the install.exe application. 
 
Follow the instructions to fully install the software. 
 

http://www.wavewin.net/
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Figure 1.1  Destination Folder 
 
Define the destination folder for the system files then click Next to start the installation.  
 
The destination folder is the location where all files are to be copied. Use the browse button to select an 
existing folder.
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Figure 1.2  Finish Install 
 
The install is now complete click Finish to end the installation. 
 

Starting the Software 
 
After you have installed the software on your computer, you are ready to begin.  How you begin depends on 
your own style.  If you like to dive right in and learn by doing the system provides on-line help to assist you.  
If you prefer a structured learning approach, read the quick start chapters to get familiar with the software. 

 
To run the software, click on the installed desktop icon or open the Start menu, navigate to the installed 
Program folder and click on the Wavewin32 shortcut. 

 

Technical Support 

Although this system is easy to use and understand, at some point you may encounter a technical question, 
feel that the system has improperly operated, or have suggestions for future improvements. In either case, 
contact Softstuf using one of the following methods: 

 
Phone:  215-922-6880, hours are from 9:00 a.m. to 6:00 p.m. Mon- Fri, (EST). 
Fax:  215-625-2497, response time is 24 hours.  
E-mail:  support@softstuf.com, response time 24 hours. 

mailto:support@softstuf.com
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C H A P T E R  2  

Dispatch Table Quick Start 
 

The Dispatch Table is used to request event files and meter information upon demand from one or more 
devices.  
 
The dispatch table communicates to the Wavewin device manager through message files saved in the 
message folder. The message folder is defined in both the dispatch table (Dispatch Properties dialog) and 
the device manager (Save & Archive dialog). These fields must point to the same folder. The device 
manager polls the device(s) specified by the message files and responses with either an “Unable to 
Connect” or “Poll Complete” status.  
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 2.1  Dispatch Table and Device Manager 

Dispatch Example 

The Dispatch Table columns are created from the fields exported from the device manager, the fields in the 
event filenames and from the message files stored in the message folder.  
 
The dispatch table will not open if the “Master Station,Station ID,Station Name.txt” does not exist in the 
message folder. Refer to “Exporting devices to the Dispatch Table” in the Device Manager Quick Start for 
more information on how to export the device manager fields. 
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Figure 2.2  Dispatch Table 
 
The columns in the table are described in the following table. Not all columns are applicable for all devices.  
 

Columns Description Source 

Dev-ID The device number assigned to the device in the 
device manager table. 

Device Manager 

Station The station name listed in the device manager’s 
group name field. The station is separated from 
the group name with a dash (-). Example: RIVER-
SOUTH ARKEY   

Device Manager 

Group The group name listed in the device manager’s 
group name field. The station is separated from 
the group name with a dash (-). Example: RIVER-
SOUTH ARKEY   

Device Manager 

Dev-Name The device name assigned in the device manager 
title field. 

Device Manager 

DB Recs The total number of event files for the device 
located in the event folder. 

Event Folder 

Line Len. The length of the line associated with the device.  
The line length is added to the filename’s eighth 
field (if available in the file) when the file is saved 
in the device manager. Refer to the Long File 
Naming Format section for more information on 
the structure of the file names.   

Filename Fields 

Location The fault location of the event contained in the 
file. The fault location is added to the filename’s 
ninth field (if available in the file) when the file is 
saved in the device manager. Refer to the Long 
File Naming Format section for more information 
on the structure of the filenames.   

Filename Fields 

Type The type of fault for the event contained in the file. 
The fault type is added to the filename’s tenth 
field (if available in the file) when the file is saved 
in the device manager. Refer to the Long File 
Naming Format section for more information on 
the structure of the filenames.   

Filename Fields 

Date of Fault The date of the fault listed in the file. The date of Filename Fields 
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Columns Description Source 

the fault is added to the filename’s first field when 
the file is saved in the device manager. Refer to 
the Long File Naming Format section for more 
information on the structure of the filenames.   

Time of Fault The time of the fault listed in the file. The time of 
the fault is added to the filename’s second field 
when the file is saved in the device manager. 
Refer to the Long File Naming Format section for 
more information on the structure of the 
filenames.   

Filename Fields 

Status The status of polling for the device. Refer to the 
Dispatch Polling section for more information on 
how devices are polled. 

Message Folder 

Poll Requested At The date and time the last poll was requested for 
the device. 

Message Folder 

Poll Completed At The date and time the last poll was completed for 
the device. 

Message Folder 

Poll Devices The device number sequence to poll to download 
the latest events and meter information from the 
device.  

Device Manager 

Event Files The path and filename of the latest event 
downloaded. 

Event Folder 

Open the Dispatch Table 

The dispatch table can be opened 3 ways, from the file manager, from the device manager and through a 
command line parameter. To open the Dispatch Table from the file manager, select the “Dispatcher 
Table…” menu option under the “Options” menu. To open the Dispatch Table from the device manager, 
select the “Dispatcher Table…” menu option under the “Options” menu. The command line option is 
described in the next section.  
 
The first time the dispatch table is opened the “Dispatch Properties” dialog is displayed. The “Message & 
Logs Path” and the “Event Path” must be specified prior to opening the dispatch table. These folders must 
be the same folders defined in the “Save & Archive” dialog in the device manager. Enter the folder where 
the polling messages are saved and enter the folder where the event files are saved. 
 
The dispatch table also has an automatic refresh option that will automatically refresh the event and status 
information. To turn the automatic refresh option on, click on the “Turn ON Automatic Refresh” checkbox.  
Checked = ON. Also, enter the automatic refresh period. The period is specified in seconds. The default is 
30 seconds. 
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Figure 2.3  Dispatch Properties Dialog 

COMMAND LINE PARAMETER 

The Dispatch Table can be automatically opened when Wavewin runs using the command line 
parameters. To add the “dispatcher” command line parameter opposite click on the Wavewin icon or 
shortcut. Add “dispatcher” after the Wavewin folder and filename in the target field.  . 
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Figure 2.4  Dispatch Table – Command Line Parameter 

Dispatch Polling 

Polling of the devices is initiated from the Dispatch table. To request a poll first mark all the devices to poll. 

Marked devices are displayed in red. Next, click on the Poll Request button  in the button menu or select 
the “Request Poll” menu option under the “Options” menu. A message dialog is displayed listing the current 
status of each device requested.  
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Figure 2.5  Poll Status Message 

 
The devices that can be polled are listed under the “initiated” list and the devices that are already scheduled 
to be polled are listed under the “already in progress” list. The “Status”, “Poll Initiated At” and “Poll Complete 
At” columns display the status of the poll. The “Status” column has the following updates: 
 

• Poll Requested: When a poll is requested the dispatch table saves a POL message in the 
message folder for each device marked. The Status column is updated with “Poll Requested” and 
the Poll Requested At column is updated with the date and time the poll was requested. 
 

• Poll in Progress: The device manager monitors the message folder for POL files. Once it sees a 
POL file it starts the polling process and renames the POL file to a CAL file indicating the poll is in 
progress. The dispatch table also monitors the message folder. When it sees a CAL file it updates 
the Status column to “Poll in Progress”. 
 

• New Files: During the polling process the dispatch table checks if new event files were 
downloaded. At each automatic refresh period the dispatch table will count the number of event files 
in the events folder. It the number of event files counted is greater than the device’s DB Recs 
column then the Status column is updated with “New Files”. 
 

• Poll Complete: When a poll is successfully completed the device manager will rename the CAL file 
to a DON file. The dispatch table will update the Status column with “Poll Complete” and update the 
Poll Completed At column with the date and time the poll completed.  
  

• Unable to Connect: When the device manager encounters a problem connecting to the device the 
CAL file is renamed to an NCR file. The dispatch table will update the Status column with “Unable to 
Connect” and update the Poll Completed At column with the date and time the poll completed. 

Table Features 

The following sections describe the main features in the dispatch table.  
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REQUESTING A POLL 

To request a poll first mark the devices to poll. Next, either click the poll request button in the button menu 

 or select the “Request Poll” menu option under the “Option” menu.  
 
The status of the poll is displayed in the “Status”, “Poll Requested At” and “Poll Completed At” columns. 
The “Status” column updates when the poll is started and when it is completed. It also indicates if new 
event files have been downloaded. The “Poll Requested At” displays the date and time the last poll was 
requested. The “Poll Completed At” is updated once the poll has been completed. The time difference 
between the Poll Requested At and the Poll Completed At shows how long it took to complete the poll. 

DISPLAYING EVENT FILES 

All the events downloaded from the devices are saved to the events folder. To list the events for a specific 
device double click on the device in the dispatch table. All event, history and summary files for the 
selected device are marked and group at the top of the file manager table. 
 

 

Figure 2.6  Event List 
 

To view only the event files first select the device then click on the “View Events” button  in the button 
menu or select the “View Events…” menu option under the “Options” menu. To view only the history files 

click on the “View History” button  or select the “View History…” menu option under the “Options” menu. 
 

To return to the dispatch table press the ESC key in the file manager or click the “Back” button  in 
the system toolbar. 

VIEWING METER INFORMATION 

Each time a device is polled the meter information is also downloaded (VA, VB, VC, & IA, IB IC). To view 

the meter values select the desired device then click on the “Meter Information” button  in the button 
menu or select the “View Meter Values…” menu option under the “Options” menu. The meter information 



Chapter 2 – Dispatch Table Quick Start 

12 

 

is displayed is an ASCII text editor. To return to the dispatch table press the ESC key in the ASCII editor 

or click the “Back” button  in the system toolbar. 
 

 

Figure 2.7  Meter Information 

REFRESH THE TABLE 

The Dispatch Table columns can be manually or automatically refreshed. To have the table automatically 
refreshed open the “Dispatch Properties” dialog from the “Options” menu. 
 

 

Figure 2.8  Automatic Refresh 
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Click on the “Turn ON Automatic Refresh” checkbox. If the box is checked the automatic refresh is ON. 
Also, enter the refresh period. The period is measured in seconds. The default is 30 seconds. The 
automatic refresh will update the event and status columns only. 
 

To manually refresh the table click on the Refresh button  in the button menu. All of the columns in the 
table are updated. 

CUSTOMIZING THE DISPATCH TABLE 

The columns displayed in the table can be repositioned through the “Table Properties” menu option under 
the “Options” menu. Use the Move Up and Move Down buttons to change the position of a column. The 
table columns can also be resized. Position the mouse over the column separator in the table and drag 
the mouse to the desired location or double click on a column separator to resize the column to the largest 
display.  
 
The size of the font displayed in the table can also be changed. Use the “Table Font Size” drop down list 
to select the desired font. 
 
The way a device is selected (marked) in the table is defined in the “File Marking” field. To follow the 
Window’s convention, select the “Windows- Ctrl-Click” selection. To have a file selected, using a single 
mouse click, select the “Single Mark Click” selection. The Single Mark Click toggles a device from selected 
(marked) or unselected. 
 

 

   Figure 2.9  Device Display Dialog 

QUERYING DEVICES 

The query fields are used to search for specific information in the dispatch table. Query fields are located 
below the table. Use the tab key to move the cursor from the device table to the query fields and the up 
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arrow to return to the table. Use the Ctrl-Left/Right arrow keys to move between the query fields. Each 
field contains a criteria and an operator. 
 
The criterion is directly entered from the keyboard, and may include the “*” and “?” wild cards. Operators 
are located above the criteria fields and can be changed by clicking the mouse button on the operator 
symbol or by pressing the F9 key. The selectable options include equal to (=), less than (<), and greater 
than (<). 
 

 
Figure 2.10  Query Fields 
 
When a query is launched, the engine numerically compares the specified criteria with the information in 
the table. If numerical comparison is not possible then it symbolically compares. When multiple fields are 
defined, the engine searches for a match on the first field “AND” on the second field “AND” on the third 
field and so on. 
 
Three query options are available: Query All, Query Marked, or Query Unmarked. Devices that meet the 
specified query requirements are marked, grouped, and displayed at the top of the table. Use the tab and 
Ctrl-Left/Right arrow keys to navigate through the query fields and the <enter> key to execute the query. 

SORTING DEVICES 

The column headers displayed at the top of the table are used to sort the devices in ascending or 
descending order. Use the Sort menu options to sort all or marked devices with respect to the selected 
sort field. To set the sort field, place the cursor in the desired column and select “Set Sort Field” from the 
“Sort” menu. Clicking on the column header also sets the active sort field. The active sort field is displayed 
in the status bar at the bottom of the window. The active sort column header displays the sort order 

. 

MARKING/UNMARKING DEVICES 

Devices are marked and unmarked through the “Mark” menu option, the spacebar, or the mouse button. 
Use the shift+mouse click button to mark a group of devices or the ctrl+mouse click button to randomly 
mark devices. Marked devices are displayed in red and can be grouped (Alt+M,G), sorted (Alt+S), printed 
(Alt+P,P) or polled (Alt+O,R). 

DELETNG DEVICES 

Devices must be marked in order to delete them from the table. To delete a device, mark the device and 
press the delete key or select “Delete” from the “File” menu. The software prompts for confirmation, click 
Yes to continue or No to Cancel.  
 
Devices that are deleted from the Dispatch table will be restored the next time the Dispatch Table is 
opened or a manual refresh is selected. 

SAVING THE DISPATCH TABLE 

The device information listed in the Dispatch table can be saved to a .csv file. When the dispatch table is 
opened all the device information displayed in the columns is saved to the Dispatchers Table.csv file 
located in the Wavewin folder. To save the current state of the dispatch table to this file select the “Save” 
menu option under the “File” menu. 
 
To save the current state of the Dispatch table to a new file select the “Save As…” menu option under the 
“File” menu. The window’s “Save As” dialog is displayed. Select the destination folder and enter the 
filename using the .csv file extension. The dispatch files can be used for generating report files. 
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C H A P T E R  3  

Fault Data Manager Quick Start 
 

The Fault Data Manager is used to manage fault files named using the IEEE Long File Naming Format 
(C37.232). The Wavewin Master Station polls the connected devices for event, summary and history files. 
All files extracted from the devices (DFRs, Relays, Meters and more) are saved using the IEEE Long File 
Naming Format (C37.232). The fault data manager also allows for requesting an immediate poll of all 
marked devices. The device table located in the top right section of the window sends messages to the 
Wavewin master station requesting to poll all the marked devices for the latest event, summary and history 
files. The Status, Poll Requested At and Poll Completed At columns list the current state of a poll request. 
 

 

Figure 3.1  Fault Data Manager 

 
The folder tree located on the left side of the window allows for navigating the local drives and all networked 
drives. When the window is first displayed the folder tree points to the active folder in the File Manager. To 
change the active folder click on the desired folder/drive listed in the folder tree. The table displayed in the 
top right section of the window lists all the devices that have long file naming event files located in the active 
folder. When the folder is scanned the device table compiles a list of unique devices according to the 
information listed in the long filenames. For more information on the IEEE C37.232 format refer to the Long 
File Naming Format section below. If there are no files, named using the long file naming format, in the 
active folder then "No Items To View" is displayed in the device table. 
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Fault Data Manager Sections 

The Fault Data Manager window has 4 sections: the Folder Tree, the Device Table, the Query Bar and the 
Device Summary Information section. The Tab key toggles between the 4 sections. 
 
The 4 window sections are described in the following sections: 

FOLDER TREE 

Summary: 
 
The Folder Tree is used to navigate through all folders on the local drives and networked drives. The 
active folder is displayed in the window's header. To change the active folder click on the desired folder 
node in the tree. If the subfolders are not displayed, click on the "+" icon to open the folder. 

 

Functions  

Change Folder To change the active folder click on the folder in the tree, or click on the 
UP menu button to change to the parent folder, or open the "File" menu 
and select the "Change Folder" option to specify the desired folder. 

Create a New Folder To create a new folder under the active folder open the "File" menu then 
select the "New Folder" menu option or opposite click in the tree and 
select the "New Folder" option from the popup menu. A new folder will 
be created under the active folder with the named defaulted to "New 
Folder". Type the new folders name and press enter. 

Rename a Folder To rename the selected folder open the "File" menu then select the 
"Rename Folder" menu option or opposite click in the tree and select the 
"Rename" option from the popup menu. The edit box for the active folder 
is activated, type the new name and press enter. 

Delete a Folder To delete the active folder opposite click in the tree and select the 
"Delete" option from the popup menu. The folder and all files and sub-
folders will be moved to the recycle bin. 

Refresh Tree To refresh the tree open the "File" menu then select the "Refresh" menu 
option or opposite click in the tree and select the "Refresh" option from 
the popup menu. The tree and device table will be refreshed with the 
latest information in the folders. 

Close Tree Close the Folder tree. To reopen the tree open the "File" menu then 
select the "Show/Hide Folder Tree" menu option or click on the first 
menu button. 

DEVICE TABLE 

Summary: 
 
The Device Table  lists all devices that have event files located in the active folder. If a Wavewin master 
station is installed then poll upon demand commands can be sent directly to the master station from the 
device table. To set up the poll upon demand from the device table open the "Options" menu and select 
the "Fault Manager Properties" option. Enter the shared "Messages & Logs" folder into the "Messages & 
Logs Path" field. 
 
The Device Table columns are populated from the fields in the IEEE Long event filenames (Company, 
Station, Device, Type, Line Length, Location, Dev-ID and Latest Event), and from the message files stored 
in the "Messages & Logs" folder (Status, Poll Requested At and Poll Completed AT). The table fields are 
described below: 
 
Table Columns: 



Chapter 3 – Fault Data Manager Quick Start 

17 

 

 

Company The company that owns the device. The company name is stored in the 
6th field in the event files. 

Station The station name. The station is stored in the 4th field in the event files. 

Device The device name. The device name is in the 5th field in the filename. 

# Event Files The number of event files located in the active folder for the device. 

Date & Time of Fault The date and time of the latest event in the active Folder. The date and 
time of the fault is the first and second fields in the filename. 

Type The type of fault from the latest event file. The fault type is stored in the 
filename’s tenth field (if available in the file). 

Line Len The length of the line read from the device's latest event file. The line 
length information is stored in the filename’s eighth field (if available 
during polling). 

Location The fault location from the device's latest event file. The fault location is 
stored  in the filename’s ninth field (if available in the file). 

Dev-ID The device number assigned to the device at the master station. 

Status The current status of the poll. 

Poll Requested At The date and time the last request for polling. 

Poll Completed At The date and time the last poll was completed. 

Latest Event The filename of the latest event. 

 
When the Enter key (Cr) or the Left Mouse Double Click is detected, the table inspects the device at the 
cursor position, and executes the driver type associated with that device and plots the latest event for that 
device. 
 

Functions  

Mark To mark/unmark a device in the device table use the space bar or 
Ctrl+left mouse button. To mark/unmark multiple devices use the 
shift+left mouse button, shift+up arrow, shift+down arrow or the mark 
menu options. 

Sort The column headers displayed at the top of the table are used to sort all 
the devices in the table. Click the header buttons to toggle between 
ascending and descending order or use the Sort menu options to sort all 
or marked files with respect to the selected sort field. To change the sort 
field, place the cursor in the desired column and select “Set Sort Field” 
from the Sort menu. The active sort field is displayed in the status bar at 
the bottom of the window. 

Plot To open the latest event file from a device double click on the device. 

Copy To copy all the event files from the marked device(s) to a new folder click 
on the copy menu button or select the "Copy To..." menu option under 
the "Files" menu. Enter or select the destination folder and click "OK". 

Move To move all the event files from the marked device(s) to a new folder 
click on the move menu button or select the "Move To..." menu option 
under the "Files" menu or drag the marked devices to a folder  displayed 
in the tree. 

QUERY BAR 

Summary: 
 
The Query Section allows for searching for devices in the active device table. A query field is provided at 
the bottom of each table column. 
 
A query field is composed of two items: a query value or criteria, and a query operator.  The query criteria 
is directly entered from the keyboard and may include wild cards: "*", and "?".  The query editor is 
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activated by clicking the left mouse button over the desired query criteria box.  The query operators can be 
changed from the Query/Change Operator menu option, or by using the (F9) key or the left mouse button 
positioned over the desired query operator box.  The action of each available operator is explained below: 
 

• (=)  Search for files that match the set query. 

• (<)  Search for files that are less than the set query. 

• (>)  Search for files that are greater than the set query. 
 
The query mechanism numerically compares the specified query with the available data columns.  If 
numerical comparison is not possible then it will symbolically compare.  When multiple query fields are 
specified, it will search for a match on the first field "AND" on the second field "AND" on the third ...  After 
a query is executed the rows that match the specified query are marked and grouped at the top of the 
table. Use the Ctrl-left/right arrows to move between query fields or left click on the desired query criteria 
field. 

 

Functions  

All Files Query All Devices in the Device table. 

Marked Files Query only the marked devices in the Device table. 

Unmarked Files Query only the unmarked devices in the Device table. 

Clear Query Area Clear the entire query area. 

Change Operator Change the operator at the active column. 

DEVICE INFORMATION 

Summary: 
 
The Device Information  section lists a history of the event files for the device selected in the device table. 
The number of event files listed can be changed by opening the "Fault Manager Properties" dialog under 
the "Options" menu. Change the "# of Event Files" field to the desired number to display.  
 
The station name, device title and the total number of events files stored in the active folder for the 
selected device is displayed in the header section of the summary window. If the devices are being polled 
by Wavewin then the last meter reading is displayed under the history list.  
 
Each file listed in the history can be plotted, viewed/edited and summarized. To plot one of the files use 
the tab key to activate the device information section or click in the section. The up arrow, down arrow, 
page up and page down keys are used to move the cursor. The enter key will plot the highlighted file, F2 
will display the contents of the file and the F3 will show a summary. Double clicking on the file will also plot 
the file.  
 
There are 3 buttons displayed in header section that will plot, summarize or view/edit the selected file. 
 

Functions  

Navigate Move the cursor, up arrow, down arrow, page up, page down or default 
mouse click. 

Plot Plot the file at the cursor, enter key or double click on the file or click on 
the plot button. 

View/Edit View the contents of the file, F2 key or click on the view/edit button. 

Summarize View a summary of the file, F3 key or click on the summary button. 

LONG FILE NAMING FORMAT (C37.232) 

All the data downloaded from the connected devices are saved to a file using the IEEE long file naming 
format. The IEEE long file naming format is a PSRC format used to name time sequenced data files. The 
file name contains the following ten fields stored in a comma-delimited fashion: 
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Example:  000112,123433234,-5S,South Arkey,DLP1,Sun Power,T,123.22,+34,60,AG T.OCS 

 
Field Definitions: 
 

Field Example Displayed Definition 

Date 040112 01/12/2004 The Date field defines the start date of the file.  
The date fields are stored as: year (2 
characters), month and day.  

Time 123433234 12:34:33.234 The time field defines the start time of the file.  
The Time fields are defined as: hour, minutes, 
seconds and milliseconds.  

Tcode -5S -5S The Time Code defines the time offset from 
GMT time.  -5s would be specified for US 
Eastern Standard Time. If the start time is 
expressed in UT, this field is coded 0z.  
Note: GMT is the international abbreviation for 
Greenwich Mean Time.  

Substation South Arkey South Arkey The substation name or code where the 
originating device is located. 

Device DLP1 DLP1 The device name or code that generated the 
file.  

Company Sun Power Sun Power The company of the specifed substation.  

File Tag T T The fault type or contents type of the file.  

Line Length 123.22 123.22 The line length extracted from the event file. 
This field applies to certain relays.  

Fault 
Location 

+34.60 +34.60 The fault location extracted from the event file. 
This field applies to certain relays.  

Fault Type AG T AG T The fault type extracted from the event file. 
This field applies to certain relays.  

Open the Fault Data Manager 

The Fault Data Manager can be opened 3 ways, from the file manager, from the device manager and 
through a command line parameter. To open the fault data manager from the file manager, select the “Fault 
Data Manager…” menu option under the “Options” menu. To open the fault data manager from the device 
manager, select the “Fault Data Manager…” menu option under the “Options” menu. The command line 
option is described in the next section.  
 
To setup polling of the devices from the fault data manager open the “Fault Manager Properties” dialog from 
the “Options” menu. Enter the shared path between the device manager polling station and the fault data 
manager in the “Messages & Log Path” This folder must be the same folder defined in the “Save & Archive” 
dialog in the device manager. 
 
The fault data manager also has an automatic refresh option that will automatically refresh the event and 
status information. To turn the automatic refresh option on, click on the “Turn ON Automatic Refresh” 
checkbox. Checked = ON. Also, enter the automatic refresh period. The period is specified in seconds. The 
default is 60 seconds. 
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Figure 3.2  Fault Data Manager Properties Dialog 

COMMAND LINE PARAMETER 

The Fault Data Manager can be automatically opened when Wavewin runs using the command line 
parameters. To add the “fault” command line parameter opposite click on the Wavewin icon or shortcut. 
Add “fault” after the Wavewin folder and filename in the target field. 
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Figure 3.3  Fault Data Manager – Command Line Parameter 

Fault Data Manager Polling 

Polling of the devices is initiated from the Device table. To request a poll first mark all the devices to poll. 

Marked devices are displayed in red. Next, click on the Poll Request button  in the button menu or select 
the “Request Poll” menu option under the “Options” menu. A message dialog is displayed listing the current 
status of each device requested.  
 



Chapter 3 – Fault Data Manager Quick Start 

22 

 

 

Figure 3.4  Poll Status Message 

 
The devices that can be polled are listed under the “initiated” list and the devices that are already scheduled 
to be polled are listed under the “already in progress” list. The “Status”, “Poll Requested At” and “Poll 
Completed At” columns display the status of the poll. The “Status” column has the following updates: 
 

• Poll Requested: When a poll is requested the device table saves a POL message in the messages 
& logs folder for each device marked. The Status column is updated with “Poll Requested” and the 
Poll Requested At column is updated with the date and time the poll was requested. 
 

• Poll in Progress: The device manager monitors the message folder for POL files. Once it sees a 
POL file it starts the polling process and renames the POL file to a CAL file indicating the poll is in 
progress. The fault data manager also monitors the message folder. When it sees a CAL file it 
updates the Status column to “Poll in Progress”. 
 

• New Files: During the polling process the fault data manager checks if new event files were 
downloaded. At each automatic refresh period the fault data manager will count the number of event 
files in the active folder. If the number of event files counted is greater than the number of events 
listed in the “# Event Files” column then the Status column is updated with “New Files” and the date 
time in the system toolbar blinks red. 
 

• Poll Complete: When a poll is successfully completed the device manager will rename the CAL file 
to a DON file. The fault data manager will update the Status column with “Poll Complete” and 
update the Poll Completed At column with the date and time the poll completed.  
  

• Unable to Connect: When the device manager encounters a problem connecting to the device the 
CAL file is renamed to an NCR file. The fault data manager will update the Status column with 
“Unable to Connect” and update the Poll Completed At column with the date and time the poll 
completed. 
 

LIST DEVICES 

If  event files are not currently listed in the Fault Data Manager’s device table for a specific device then the 
device can be polled using the “List Devices” dialog. This will occur if it is a new device added to the 
device manager polling station and it has not been polled yet or all the device’s events files where 
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archived to an archive path. To open the “List Devices” dialog select the “List Devices…” menu option 
under the “Options” menu  
 

 

Figure 3.5  List Devices 

 
To poll devices from the “List Devices” dialog first marked the devices using the Ctrl mouse click on all 
devices to poll then click on the “Poll Devices” button. The Status and Poll Requested At columns in the 
device table are updated. 

Table Features 

The following sections describe the main features in the Fault Data Manager’s device table.  

REQUESTING A POLL 

To request a poll first mark the devices to poll. Next, either click the poll request button in the button menu 

 or select the “Request Poll” menu option under the “Option” menu.  
 
The status of the poll is displayed in the “Status”, “Poll Requested At” and “Poll Completed At” columns. 
The “Status” column updates when the poll is started and when it is completed. It also indicates if new 
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event files have been downloaded. The “Poll Requested At” displays the date and time the last poll was 
requested. The “Poll Completed At” is updated once the poll has been completed. The time difference 
between the Poll Requested At and the Poll Completed At shows how long it took to complete the poll. 

DISPLAYING EVENT HISTORY 

All the events downloaded from the devices are saved to the events folder using the IEEE long file naming 
format. A history list of the event files are displayed in the Device Information section. To plot, view/edit or 
view a summary of the events tab to the device information section and move the event cursor to the 
desired event file. To plot the file press the enter key or double click on the event file or click on the “Plot” 

button  displayed in the upper right corner. To view a summary of the event, click on the “Summary” 

button . To view/edit the event’s raw file click on the “Edit” button . 
 

 

Figure 3.6  Event History List 

VIEWING METER INFORMATION 

Each time a device is polled the meter information is also downloaded (VA, VB, VC, & IA, IB IC). To view 
the latest meter values move the cursor to the desired device in the device table. The “Device Information” 
section list the latest history of events along with the latest meter information. Tab to the “Device 
Information” section and use the scroll bar to show the latest meter information. 
 

 

Figure 3.7  Meter Information 
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REFRESH THE TABLE 

The device table columns can be manually or automatically refreshed. To have the table automatically 
refreshed open the “Fault Manager Properties” dialog from the “Options” menu. 
 

 

Figure 3.8  Automatic Refresh 
 
Click on the “Turn ON Automatic Refresh” checkbox. If the box is checked the automatic refresh is ON. 
Also, enter the refresh period. The period is measured in seconds. The default is 60 seconds. The 
automatic refresh will update the event and status columns. 
 

To manually refresh the table click on the Refresh button  in the button menu. All of the columns in the 
table are updated. 

CUSTOMIZING THE DISPATCH TABLE 

The columns displayed in the device table can be repositioned through the “Table Properties” menu option 
under the “Options” menu. Use the Move Up and Move Down buttons to change the position of a column. 
The table columns can also be resized. Position the mouse over the column separator in the table and 
drag the mouse to the desired location or double click on a column separator to resize the column to the 
largest display.  
 
The size of the font displayed in the table can also be changed. Use the “Table Font Size” drop down list 
to select the desired font. 
 
The way a device is selected (marked) in the table is defined in the “File Marking” field. To follow the 
Window’s convention, select the “Windows- Ctrl-Click” selection. To have a file selected, using a single 
mouse click, select the “Single Mark Click” selection. The Single Mark Click toggles a device from selected 
(marked) or unselected. 
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Figure 3.9  Table Properties Dialog 

QUERYING DEVICES 

The query fields are used to search for specific information in the device table. Query fields are located 
below the table. Use the tab key to move the cursor from the device table to the query fields and the up 
arrow to return to the table. Use the Ctrl-Left/Right arrow keys to move between the query fields. Each 
field contains a criteria and an operator.  
 
The criterion is directly entered from the keyboard, and may include the “*” and “?” wild cards. Operators 
are located above the criteria fields and can be changed by clicking the mouse button on the operator 
symbol or by pressing the F9 key. The selectable options include equal to (=), less than (<), and greater 
than (<). 
 

 
Figure 3.10  Query Fields 
 
When a query is launched, the engine numerically compares the specified criteria with the information in 
the table. If numerical comparison is not possible then it symbolically compares. When multiple fields are 
defined, the engine searches for a match on the first field “AND” on the second field “AND” on the third 
field and so on. 
 
Three query options are available: Query All, Query Marked, or Query Unmarked. Devices that meet the 
specified query requirements are marked, grouped, and displayed at the top of the table. Use the tab and 
Ctrl-Left/Right arrow keys to navigate through the query fields and the <enter> key to execute the query. 
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SORTING DEVICES 

The column headers displayed at the top of the table are used to sort the devices in ascending or 
descending order. Use the Sort menu options to sort all or marked devices with respect to the selected 
sort field. To set the sort field, place the cursor in the desired column and select “Set Sort Field” from the 
“Sort” menu. Clicking on the column header also sets the active sort field. The active sort field is displayed 
in the status bar at the bottom of the window. The active sort column header displays the sort order 

. 

MARKING/UNMARKING DEVICES 

Devices are marked and unmarked through the “Mark” menu option, the spacebar, or the mouse button. 
Use the shift+mouse click button to mark a group of devices or the ctrl+mouse click button to randomly mark 
devices. Marked devices are displayed in red and can be grouped (Alt+M,G), sorted (Alt+S), printed 
(Alt+P,P) or polled (Alt+O,R). 
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A P P E N D I X  A  

System Keys 
 
This section lists the function keys, cursor keys, and menu buttons available in the system monitors. 

Device Manager 

Function Keys Description 

F1 Display the device manger’s help file.  

F2 Edit the device record at the cursor position.  

F3 Test the device’s port at the cursor positon using the loop back plug detection test. 

F4 Create a new device. 

F5 Create or edit the terminal function keys for the device at the cursor position. 

F6 View the data stored in the device buffer. 

F7 Run the MID interrogration interface for all or marked devices assigned a device 
driver. 

F8 Run the DXF interrogration interface for all devices assigned a device driver. 

 

Cursor Keys Description 

Left Arrow Move the cursor bar to the left one position. 

Right Arrow Move the cursor bar to the right one position. 

Up Arrow Move the cursor bar up one position. 

Down Arrow Move the cursor bar down one position. 

Page Up Display the devices on the previous page. 

Page Down Display the devices on the next page. 

Home  Move the cursor to the first column in the port table. 

End Move the cursor to the last column in the port table. 

Ctrl+Home Move the cursor to the first device in the table. 

Ctrl+End Move the cursor to the last device in the table. 

Tab Move the cursor from the device table to the query fields. 

Delete Delete all the marked devices in the table. 

Enter Run the terminal display for the selected device. 

 

Menu Buttons Description 

 Configure Edit the device at the cursor position 

 New Create a new device. 

 TermKeys 
Create or edit the terminal function keys for the device at the cursor position. 

 Terminal Run the terminal display for the selected device. 

 EventFile 
View the data stored in the device buffer. 

 MID Run the MID interrogation display for all or marked devices assigned device drivers. 

 DXF 
Run the DXF interrogation display for all devices assigned device drivers. 
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Query Fields 

Function Keys Description 

F1 Display the query help file.  

F5 Query all the marked devices in the active configuration.  

F6 Query all the devices in the active configuration. 

F7 Query all the unmarked devices in the active configuration. 

F8 Clear the query criteria and set all the query operators to “=”. 

F9 Toggle through the available query operators for the active query field. 

 

Cursor Keys Description 

Up Arrow Return the cursor to the device table. 

Right Arrow Move the cursor one position to the right, wraps to next field at the end. 

Left Arrow Move the cursor one position to the left, wraps to next field at the beginning. 

Tab Move the editor to the next query field. 

Shift+Tab Move the editor to the previous query field. 

Enter Process the query criteria for all devices in the active configuration. 

 

Menu Button Description 

 Query 
Query all devices in the active configuration. 

DXF Display 

Function Keys Description 

F1 Display DXF mode's help window.  

F2 Display the “Drawing Properties” dialog.  

 

Cursor Keys Description 

Up Arrow Move the viewing area of the drawing up 40 pixels.  

Down Arrow Move the viewing area of the drawing down 40 pixels. 

Right Arrow Move the viewing area of the drawing to the right 40 pixels. 

Left Arrow Move the viewing area of the drawing to the left 40 pixels. 

Ctrl+Right Move the viewing area of the drawing to the right by one screen. 

Ctrl+Left Move the viewing area of the drawing to the left by one screen. 

Page Up Move the viewing area of the drawing up by one screen. 

Page Down Move the viewing area of the drawing down by one screen. 

Home Display the far left portion of the drawing. 

End Display the far right portion of the drawing. 

Ctrl+Home Display the top left portion of the drawing. 

Ctrl+End Display the bottom right portion of the drawing. 

Tab Move to the next DXF drawing tab 

Shift+Tab Move to the previous DXF drawing tab 

+ key Increase the drawing's resolution. 

- key Decrease the drawing's resolution. 
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Menu Buttons Description 

 Original  Display the drawing in the original coordinates.  

 Fit in Win Fit the full drawing to fit in the screen area. 

 Zoom-In 
Increase the drawing's resolution. 

 Zoom-Out 
Decrease the drawing's resolution. 

 Print Print the DXF drawing in the selected DXF tab. 

 Const Set the drawing properties for the active DXF drawing. 

 Refresh Refresh the polled values in the selected DXF drawing. 

 Control  Display the control dialog to send control commands to the connected devices. 

Dispatch Table 

Cursor Keys Description 

Left Arrow Move the cursor bar to the left one position.  

Right Arrow Move the cursor bar to the right one position. 

Up Arrow Move the cursor bar up one position. 

Down Arrow Move the cursor bar down one position. 

Page Up Display the devices on the previous page. 

Page Down Display the devices on the next page. 

Home  Move the cursor to the first column in the port table. 

End Move the cursor to the last column in the port table. 

Ctrl+Home Move the cursor to the first device in the table. 

Ctrl+End Move the cursor to the last device in the table. 

Tab Move the cursor from the device table to the query fields. 

Delete Delete all the marked devices in the table. 

Enter Display the event, summary and history files for the selected device. 

 

Menu Buttons Description 

 Print Print all of the devices in the table. 

 Request Poll Request a poll for all of the marked devices. 

 Event Files Display the events files for the seclected device. 

 History Files Display the history files for the selected device. 

 Meter Values Display the last polled meter values for the selected device. 

 Refresh Refresh the Dispatch table. 

 Mark Mark or Unmark the marked devices. 

 Query Query the devices. 

Query Fields 

Function Keys Description 

F1 Display the query help file.  

F5 Query all the marked devices in the active configuration.  
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F6 Query all the devices in the active configuration. 

F7 Query all the unmarked devices in the active configuration. 

F8 Clear the query criteria and set all the query operators to “=”. 

F9 Toggle through the available query operators for the active query field. 

 

Cursor Keys Description 

Up Arrow Return the cursor to the device table. 

Right Arrow Move the cursor one position to the right, wraps to next field at the end. 

Left Arrow Move the cursor one position to the left, wraps to next field at the beginning. 

Tab Move the editor to the next query field. 

Shift+Tab Move the editor to the previous query field. 

Enter Process the query criteria for all devices in the active configuration. 

 

Menu Button Description 

 Query 
Query all devices in the active configuration. 

Fault Data Manager Table 

Cursor Keys Description 

Left Arrow Move the cursor bar to the left one position.  

Right Arrow Move the cursor bar to the right one position. 

Up Arrow Move the cursor bar up one position. 

Down Arrow Move the cursor bar down one position. 

Page Up Display the devices on the previous page. 

Page Down Display the devices on the next page. 

Home  Move the cursor to the first column in the port table. 

End Move the cursor to the last column in the port table. 

Ctrl+Home Move the cursor to the first device in the table. 

Ctrl+End Move the cursor to the last device in the table. 

Tab Move the cursor from the device table to the query fields. 

Enter Display the event, summary and history files for the selected device. 

 

Menu Buttons Description 

 Folder Tree Show/Hide the Folder Tree. 

 Email Email the Device Information Section. 

 Refresh Refresh the Folder Tree and Device table. 

 ChDir Change the active folder to the specified destination path. 

 Previous Dir Change to the previous directory. 

 Copy 
Copy the marked device files to the destination path. 

 Move 
Move the marked device files to the destination path. 

Mark 
Mark/Unmark all devices. 

 Query Query the devices. 

 Request Poll Request a poll for all of the marked devices. 
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Query Fields 

Function Keys Description 

F1 Display the query help file.  

F5 Query all the marked devices in the active configuration.  

F6 Query all the devices in the active configuration. 

F7 Query all the unmarked devices in the active configuration. 

F8 Clear the query criteria and set all the query operators to “=”. 

F9 Toggle through the available query operators for the active query field. 

 

Cursor Keys Description 

Up Arrow Return the cursor to the device table. 

Right Arrow Move the cursor one position to the right, wraps to next field at the end. 

Left Arrow Move the cursor one position to the left, wraps to next field at the beginning. 

Tab Move the editor to the next query field. 

Shift+Tab Move the editor to the previous query field. 

Enter Process the query criteria for all devices in the active configuration. 

 

Menu Button Description 

 Query 
Query all devices in the active configuration. 
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