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Preface 
 
This document contains information about the Wavewin Dispatch application. 
 
This document is intended for use by individuals working in protection, engineering, and system 
operations.
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C H A P T E R  1  

System Requirements & Installation 
 
This chapter lists the system requirements needed for installing and running the Wavewin software.  It 
also describes the installation procedures and provides technical support information. 

System Requirements 

The system requirements are listed below. 
 
� An IBM or compatible PC with an 80486 microprocessor or higher. 
� 500 Megabytes of memory. 
� 2 gigabytes of available hard disk space. 
� A VGA, 8514/A, or compatible graphics adapter. 
� Microsoft Windows version 98 or higher. 

Installation 

The system files are distributed in a compressed format.  To install the software follow the instruction for 
the type of storage media distributed with this manual. 
 
Web: To install the software from the Web access the www.wavewin.net web site. Under the “Wavewin 
Upgrades” link click on the Wavewin application to download. Enter your username and password. The 
username and password are case sensitive. Click on the software link to download the latest system’s 
executable files. Open the zip file and run the install.  
 
CD: To install the software using a CD place the CD into the CD drive.  The installation program will run 
automatically. If the installation program is not displayed, navigate to the CD’s root drive and double click 
on the install.exe application. 
 
Follow the instructions to fully install the software. 
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Figure 1.1  Destination Folder 
 
Define the destination folder for the system files then click Next to start the installation.  
 
The destination folder is the location where all files are to be copied. Use the browse button to select an 
existing folder.
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Figure 1.2  Finish Install 
 
The install is now complete click Finish to end the installation. 
 

Starting the Software 
 
After you have installed the software on your computer, you are ready to begin.  How you begin depends 
on your own style.  If you like to dive right in and learn by doing the system provides on-line help to assist 
you.  If you prefer a structured learning approach, read the quick start chapters to get familiar with the 
software. 
 
To run the software, click on the installed desktop icon or open the Start menu, navigate to the installed 
Program folder and click on the Wavewin32 shortcut. 

 

Technical Support 

Although this system is easy to use and understand, at some point you may encounter a technical 
question, feel that the system has improperly operated, or have suggestions for future improvements. In 
either case, contact Softstuf using one of the following methods: 
 
Phone:  215-922-6880, hours are from 9:00 a.m. to 8:00 p.m. Mon- Fri, (EST). 
Fax:  215-625-2497, response time is 24 hours.  
E-mail:  support@softstuf.com, response time 24 hours. 
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C H A P T E R  2  

Dispatch Table Quick Start 
 
The Dispatch Table is used to request event files and meter information upon demand from one or more 
devices.  
 
The dispatch table communicates to the Wavewin device manager through message files saved in the 
message folder. The message folder is defined in both the dispatch table (Dispatch Properties dialog) and 
the device manager (Save & Archive dialog). These fields must point to the same folder. The device 
manager polls the device(s) specified by the message files and responses with either an “Unable to 
Connect” or “Poll Complete” status. Refer to Figure 2.1 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 2.1  Dispatch Table and Device Manager 

Dispatch Example 

The Dispatch Table columns are created from the fields exported from the device manager, the fields in 
the event filenames and from the message files stored in the message folder. Refer to Figure 2.2.  
 
The dispatch table will not open if the “Master Station.txt” does not exist in the message folder. Refer to 
“Exporting devices to the Dispatch Table” for more information on how to export the device manager 
fields. 
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Figure 2.2  Dispatch Table 
 
The columns in the table are described in the following table. Not all columns are applicable for all 
devices.  
 

Columns Description Source 
Device Number The device number assigned to the device in the 

device manager table. 
Device Manager 

District The district name listed in the device manager’s 
group name field. The district is separated from 
the station name with a dash (-). Example: 
RIVER-SOUTH ARKEY   

Device Manager 

Station The station name listed in the device manager’s 
group name field. The district is separated from 
the station name with a dash (-). Example: 
RIVER-SOUTH ARKEY   

Device Manager 

Dev-Name The device name assigned in the device manager 
title field. 

Device Manager 

Line Len. The length of the line associated with the device.  
The line length is added to the filename’s eighth 
field (if available in the file) when the file is saved 
in the device manager. Refer to the Long File 
Naming Format section for more information on 
the structure of the file names.   

Filename Fields 

Location The fault location of the event contained in the 
file. The fault location is added to the filename’s 
ninth field (if available in the file) when the file is 
saved in the device manager. Refer to the Long 
File Naming Format section for more information 
on the structure of the filenames.   

Filename Fields 

Type The type of fault for the event contained in the file. 
The fault type is added to the filename’s tenth 
field (if available in the file) when the file is saved 
in the device manager. Refer to the Long File 
Naming Format section for more information on 
the structure of the filenames.   

Filename Fields 

Date of Fault The date of the fault listed in the file. The date of 
the fault is added to the filename’s first field when 

Filename Fields 
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Columns Description Source 
the file is saved in the device manager. Refer to 
the Long File Naming Format section for more 
information on the structure of the filenames.   

Time of Fault The time of the fault listed in the file. The time of 
the fault is added to the filename’s second field 
when the file is saved in the device manager. 
Refer to the Long File Naming Format section for 
more information on the structure of the 
filenames.   

Filename Fields 

DB Recs The total number of events files for the device in 
the event folder. 

Event Folder 

Status The status of polling for the device. Refer to the 
Dispatch Polling section for more information on 
how devices are polled. 

Message Folder 

Poll Requested At The date and time the last poll was requested for 
the device. 

Message Folder 

Poll Completed At The date and time the last poll was completed for 
the device. 

Message Folder 

Poll Devices The device number sequence to poll to download 
the latest events and meter information from the 
device.  

Device Manager 

Event Files The path and filename of the latest event 
downloaded. 

Event Folder 

Open the Dispatch Table 

The dispatch table can be opened 3 ways, from the file manager, from the device manager and through a 
command line parameter. To open the Dispatch Table from the file manager, select the “Dispatcher 
Table…” menu option under the “Options” menu. To open the Dispatch Table from the device manager, 
select the “Dispatcher Table…” menu option under the “Options” menu. The command line option is 
described in the next section.  
 
The first time the dispatch table is opened the “Dispatch Properties” dialog is displayed. The “Message 
Folder” and the “Event Folder” must be specified prior to opening the dispatch table. These folders must 
be the same folders defined in the “Save & Archive” dialog in the device manager. Enter the folder where 
the polling messages are saved and enter the folder where the event files are saved. 
 
The dispatch table also has an automatic refresh option that will automatically refresh the event and 
status information. To turn the automatic refresh option on, click on the “Turn ON Automatic Refresh” 
checkbox.  Checked = ON. Also, enter the automatic refresh period. The period is specified in seconds. 
The default is 30 seconds. 
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Figure 2.3  Dispatch Properties Dialog 

COMMAND LINE PARAMETER 
The Dispatch Table can be automatically opened when Wavewin runs using the command line 
parameters. To add the “dispatcher” command line parameter opposite click on the Wavewin icon or 
shortcut. Add “dispatcher” after the Wavewin folder and filename in the target field.  Refer to Figure 2.4. 
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Figure 2.4  Dispatch Table – Command Line Parameter 

Dispatch Polling 

Polling of the devices is initiated from the Dispatch table. To request a poll first mark all the devices to 

poll. Marked devices are displayed in red. Next, click on the Poll Request button  in the button menu 
or select the “Request Poll” menu option under the “Options” menu. A message dialog is displayed listing 
the current status of each device requested. Refer to Figure 2.5. 
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Figure 2.5  Poll Status Message 
 

The devices that can be polled are listed under the “initiated” list and the devices that are already 
scheduled to be polled are listed under the “already in progress” list. The “Status”, “Poll Initiated At” and 
“Poll Complete At” columns display the status of the poll. The “Status” column has the following updates: 
 

• Poll Requested: When a poll is requested the dispatch table saves a POL message in the 
message folder for each device marked. The Status column is updated with “Poll Requested” and 
the Poll Requested At column is updated with the date and time the poll was requested. 
 

• Poll in Progress: The device manager monitors the message folder for POL files. Once it sees a 
POL file it starts the polling process and renames the POL file to a CAL file indicating the poll is in 
progress. The dispatch table also monitors the message folder. When it sees a CAL file it updates 
the Status column to “Poll in Progress”. 
 

• New Files: During the polling process the dispatch table checks if new event files were 
downloaded. At each automatic refresh period the dispatch table will count the number of event 
files in the events folder. It the number of event files counted is greater than the device’s DB Recs 
column then the Status column is updated with “New Files”. 
 

• Poll Complete: When a poll is successfully completed the device manager will rename the CAL 
file to a DON file. The dispatch table will update the Status column with “Poll Complete” and 
update the Poll Completed At column with the date and time the poll completed.  
  

• Unable to Connect: When the device manager encounters a problem connecting to the device 
the CAL file is renamed to an NCR file. The dispatch table will update the Status column with 
“Unable to Connect” and update the Poll Completed At column with the date and time the poll 
completed. 

Table Features 

The following sections describe the main features in the dispatch table.  
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REQUESTING A POLL 
To request a poll first mark the devices to poll. Next, either click the poll request button in the button 

menu  or select the “Request Poll” menu option under the “Option” menu.  
 
The status of the poll is displayed in the “Status”, “Poll Requested At” and “Poll Completed At” columns. 
The “Status” column updates when the poll is started and when it is completed. It also indicates if new 
event files have been downloaded. The “Poll Requested At” displays the date and time the last poll was 
requested. The “Poll Completed At” is updated once the poll has been completed. The time difference 
between the Poll Requested At and the Poll Completed At shows how long it took to complete the poll. 

DISPLAYING EVENT FILES 
All the events downloaded from the devices are saved to the events folder. To list the events for a 
specific device double click on the device in the dispatch table. All event, history and summary files for 
the selected device are marked and group at the top of the file manager table. Refer to Figure 2.6. 
 

 
Figure 2.6  Event List 
 
To view only the event files first select the device then click on the “View Events” button  in the button 
menu or select the “View Events…” menu option under the “Options” menu. To view only the history 
files click on the “View History” button  or select the “View History…” menu option under the 
“Options” menu. 
 
To return to the dispatch table press the ESC key in the file manager or click the “Back” button  
in the system toolbar. 

VIEWING METER INFORMATION 
Each time a device is polled the meter information is also downloaded (VA, VB, VC, & IA, IB IC). To 

view the meter values select the desired device then click on the “Meter Information” button  in the 
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button menu or select the “View Meter Values…” menu option under the “Options” menu. The meter 
information is displayed is an ASCII text editor. Refer to Figure 2.7. To return to the dispatch table press 
the ESC key in the ASCII editor or click the “Back” button  in the system toolbar. 
 

 
Figure 2.7  Meter Information 

REFRESH THE TABLE 
The Dispatch Table columns can be manually or automatically refreshed. To have the table 
automatically refreshed open the “Dispatch Properties” dialog from the “Options” menu. Refer to Figure 
2.8. 
 

 
Figure 2.8  Automatic Refresh 



Chapter 2 –Dispatch Table Quick Start 
 

13 

 
Click on the “Turn ON Automatic Refresh” checkbox. If the box is checked the automatic refresh is ON. 
Also, enter the refresh period. The period is measured in seconds. The default is 30 seconds. The 
automatic refresh will update the event and status columns only. 
 
To manually refresh the table click on the Refresh button  in the button menu. All of the columns in 
the table are updated. 

CUSTOMIZING THE DISPATCH TABLE 
The columns displayed in the table can be repositioned through the “Table Properties” menu option 
under the “Options” menu. Refer to Figure 2.9. Use the Move Up and Move Down buttons to change 
the position of a column. The table columns can also be resized. Position the mouse over the column 
separator in the table and drag the mouse to the desired location or double click on a column separator 
to resize the column to the largest display.  
 
The size of the font displayed in the table can also be changed. Use the “Table Font Size” drop down 
list to select the desired font. 
 

 
Figure 2.9  Device Display Dialog 

QUERYING DEVICES 
The query fields are used to search for specific information in the dispatch table. Query fields are 
located below the table. Use the tab key to move the cursor from the device table to the query fields 
and the up arrow to return to the table. Use the Ctrl-Left/Right arrow keys to move between the query 
fields. Each field contains a criteria and an operator. Refer to Figure 2.10.  
 
The criterion is directly entered from the keyboard, and may include the “*” and “?” wild cards. 
Operators are located above the criteria fields and can be changed by clicking the mouse button on the 
operator symbol or by pressing the F9 key. The selectable options include equal to (=), less than (<), 
and greater than (<). 
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Figure 2.10  Query Fields 
 
When a query is launched, the engine numerically compares the specified criteria with the information 
in the table. If numerical comparison is not possible then it symbolically compares. When multiple fields 
are defined, the engine searches for a match on the first field “AND” on the second field “AND” on the 
third field and so on. 
 
Three query options are available: Query All, Query Marked, or Query Unmarked. Devices that meet 
the specified query requirements are marked, grouped, and displayed at the top of the table. Use the 
tab and Ctrl-Left/Right arrow keys to navigate through the query fields and the <enter> key to execute 
the query. 

SORTING DEVICES 
The column headers displayed at the top of the table are used to sort the devices in ascending or 
descending order. Use the Sort menu options to sort all or marked devices with respect to the selected 
sort field. To set the sort field, place the cursor in the desired column and select “Set Sort Field” from 
the “Sort” menu. Clicking on the column header also sets the active sort field. The active sort field is 
displayed in the status bar at the bottom of the window. The active sort column header displays the sort 
order . 

MARKING/UNMARKING DEVICES 
Devices are marked and unmarked through the “Mark” menu option, the spacebar, or the mouse 
button. Use the shift+mouse click button to mark a group of devices or the ctrl+mouse click button to 
randomly mark devices. Marked devices are displayed in red and can be grouped (Alt+M,G), sorted 
(Alt+S), printed (Alt+P,P) or polled (Alt+O,R). 

DELETNG DEVICES 
Devices must be marked in order to delete them from the table. To delete a device, mark the device 
and press the delete key or select “Delete” from the “File” menu. The software prompts for confirmation, 
click Yes to continue or No to Cancel.  
 
Devices that are deleted from the Dispatch table will be restored the next time the Dispatch Table is 
opened or a manual refresh is selected. 

SAVING THE DISPATCH TABLE 
The device information listed in the Dispatch table can be saved to a .csv file. When the dispatch table 
is opened all the device information displayed in the columns is saved to the Dispatchers Table.csv file 
located in the Wavewin folder. To save the current state of the dispatch table to this file select the 
“Save” menu option under the “File” menu. 
 
To save the current state of the Dispatch table to a new file select the “Save As…” menu option under 
the “File” menu. The window’s “Save As” dialog is displayed. Select the destination folder and enter the 
filename using the .csv file extension. The dispatch files can be used for generating report files. 
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A P P E N D I X  A  

System Keys 
 
This section lists the function keys, cursor keys, and menu buttons available in the device manager, query 
fields and DXF display. 

Dispatch Table 

Cursor Keys Description 
Left Arrow Move the cursor bar to the left one position.  
Right Arrow Move the cursor bar to the right one position. 
Up Arrow Move the cursor bar up one position. 
Down Arrow Move the cursor bar down one position. 
Page Up Display the devices on the previous page. 
Page Down Display the devices on the next page. 
Home  Move the cursor to the first column in the port table. 
End Move the cursor to the last column in the port table. 
Ctrl+Home Move the cursor to the first device in the table. 
Ctrl+End Move the cursor to the last device in the table. 
Tab Move the cursor from the device table to the query fields. 
Delete Delete all the marked devices in the table. 
Enter Display the event, summary and history files for the selected device. 
 
Menu Buttons Description 

 Print Print all of the devices in the table. 

 Request Poll Request a poll for all of the marked devices. 

 Event Files Display the events files for the seclected device. 

 History Files Display the history files for the selected device. 

 Meter Values Display the last polled meter values for the selected device. 

 Refresh Refresh the Dispatch table. 

 Mark Mark or Unmark the marked devices. 

 Query Query the devices. 

Query Fields 

Function Keys Description 
F1 Display the query help file.  
F5 Query all the marked devices in the active configuration.  
F6 Query all the devices in the active configuration. 
F7 Query all the unmarked devices in the active configuration. 
F8 Clear the query criteria and set all the query operators to “=”. 
F9 Toggle through the available query operators for the active query field. 
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Cursor Keys Description 
Up Arrow Return the cursor to the device table. 
Right Arrow Move the cursor one position to the right, wraps to next field at the end. 
Left Arrow Move the cursor one position to the left, wraps to next field at the beginning. 
Tab Move the editor to the next query field. 
Shift+Tab Move the editor to the previous query field. 
Enter Process the query criteria for all devices in the active configuration. 
 
Menu Button Description 

 Query 
Query all devices in the active configuration. 
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